NA01 Reporting Engine not responding
Incident Report for PatientNow / EnvisionNow
Resolved
The NA01 reporting service issue has been resolved.
Posted Apr 09, 2019 - 19:01 EDT
Update
We have identified the issue and are working on restarting the service.
Posted Apr 09, 2019 - 19:00 EDT
Investigating
We are investigating the issue.
Posted Apr 09, 2019 - 18:57 EDT
This incident affected: PatientNow/EnvisionNow Website.