Certain Clients experiencing unable to connect issues
Incident Report for PatientNow / EnvisionNow
Resolved
We have received notice that the affected area's have been restored. Internet traffic should be flowing as expected.
Posted May 23, 2018 - 11:45 EDT
Monitoring
Our service is up and running!

We have confirmed that Spectrum and Comcast are reporting partial outages this morning. This is affecting certain clients ability to connect to our service. Please check with your service provider
Posted May 23, 2018 - 10:31 EDT
This incident affected: PatientNow/EnvisionNow Website.