Update My Records Connectivity Issues
Incident Report for Envision Cloud
Resolved
The issue has been resolved.
Posted 5 months ago. Apr 03, 2019 - 13:43 EDT
Monitoring
We have identified the issue and the service is operational. We are continuing to monitor the system.
Posted 5 months ago. Apr 03, 2019 - 13:23 EDT
Investigating
We are currently receiving reports that clients cannot connect to the Update My Records Patient Portal Service. We are investigating the issue and will report shortly.
Posted 5 months ago. Apr 03, 2019 - 13:06 EDT
This incident affected: Update My Records Patient Portal.