Support Phone Outage
Incident Report for PatientNow / EnvisionNow
Resolved
The support phones are back up and working again.
Posted Jan 12, 2021 - 10:08 EST
Identified
Our phone provider is experiencing issues, and consequentially our phone support is offline. You can still email / chat with support until the phone company solves their issues.
Posted Jan 12, 2021 - 10:03 EST